Solving slow dd on OS X

One would expect a typical dd to work on Apple's OSX just as on a standard linux system:

# dd bs=1m if=2014-09-09-wheezy-raspbian.img of=/dev/disk2

But it turn out it is outrageously slow. The solution is to use /dev/rdisk instead of /dev/disk.

# dd bs=1m if=2014-09-09-wheezy-raspbian.img of=/dev/rdisk2

man hdiutil says:

Since any /dev entry can be treated as a raw disk image, it is worth noting which devices can be accessed when and how. /dev/rdisk nodes are character-special devices, but are "raw" in the BSD sense and force block-aligned I/O. They are closer to the physical disk than the buffer cache. /dev/disk nodes, on the other hand, are buffered block-special devices and are used primarily by the kernel's filesystem code.

ref @ superuser